Website or webmail is not accessible: Server not found

Refers to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 12:47:53 UTC

Modified:

2016-12-21 19:14:19 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Website or webmail is not accessible: Server not found

Symptoms

Website, and/or webmail, and/or webadmin are not accessible.

  • Firefox: Server not found
  • Opera: Could not locate remote server
  • Internet Explorer: Internet Explorer cannot display the webpage or shows This page can’t be displayed message
  • Google Chrome: This webpage is not available

Cause

  • The domain is not registered
  • DNS servers are not specified for the domain
  • DNS servers are specified but not configured
  • Domain is resolved to IP address not available in Internet, or hosting is not configured on this IP address.
  • Firewall blocks inbound connections to 80 or 443 ports

Resolution

  1. Check if the domain is registered:

    # whois example.com 
    ................
    No match for domain "example.com".
    No whois server is known for this kind of object.
    ................

    So this domain is not registered. It is required to register it before usage.

  2. Check DNS servers of this domain:

    # whois example.com
    ................
    Name Server: A.NS.EXAMPLE.COM
    Name Server: B.NS.EXAMPLE.COM
    ................

    If Name Servers are not specified, it is required to add them at registrar.

  3. Check if DNS servers are configured for the domain or not:

    # nslookup example.com A.NS.EXAMPLE.COM
    Name: example.com
    Address: 10.10.10.10

    If DNS servers are not configured it is required to set IP address for the domain.

  4. Check if hosting server is configured on the domain resolved IP address:

    Web service should be available at tcp ports 80 or 443 for https:

    # telnet 10.10.10.10 80
    Trying 10.10.10.10...
    Connected to 10.10.10.101.
    Escape character is '^]'.

    This command verifies if connection to web server can be established. If no, then web hosting service is not running on the host or firewall blocks inbound connections at tcp port 80 on the server. Add firewall rule to allow connection to 80 and 443 ports:

    # iptables -I INPUT 1 -p tcp --dport 80 -j ACCEPT 
    # iptables -I INPUT 2 -p tcp --dport 443 -j ACCEPT
  5. Ensure that website, and/or webmail, and/or webadmin is actually accessible by adding record in the ' hosts ' file and trying to access web service afterwards. For example:

    On Windows:

    C:>\\ findstr example.com "%windir%\\system32\\drivers\\etc\\hosts"
    10.10.10.10 example.com webmail.example.com mssql.example.com

    On Linux:

    # grep example.com /etc/hosts
    10.10.10.10 example.com webmail.example.com

    Do not forget to remove record from the hosts file afterwards.

Have more questions? Submit a request
Please sign in to leave a comment.