Plesk 17.0.11 to Plesk 17.0.12 preview upgrade notes

Created:

2016-11-16 12:47:36 UTC

Modified:

2017-04-24 11:01:26 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk 17.0.11 to Plesk 17.0.12 preview upgrade notes

Applicable to:

  • Plesk Onyx for Linux

Note: The public preview is meant only to demonstrate the new features. No support for Plesk 17 is provided until release. We do not recommend using the public preview in production. Some features can be changed or removed in next build or in release version.

Symptoms

After an upgrade from Plesk 17.0.11 to Plesk 17.0.12 on CentOS 7 or Debian 8, almost any command execution like ls or date thrown an error related to shared libraries load.

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/sw/libplesk_resctrl.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored. any command execution

Resolution

  1. Remove /etc/ld.so.preload

    rm -f  /etc/ld.so.preload
  2. Reboot server

  3. Re-run failed Plesk upgrade tasks to repair Plesk:

    /usr/local/psa/bootstrapper/pp17.0.12-bootstrapper/bootstrapper.sh repair

To avoid upgrade errors you need to do the following before upgrade:

  1. Remove /etc/ld.so.preload

    rm -f  /etc/ld.so.preload
  2. Reboot server (highly recommended).

    Otherwise, you need to restart all system services: apache, nginx, courier-imap*, dovecot, postfix, qmail, xinetd, drweb, ssh, syslog, network etc…

  3. Upgrade to Plesk 17.0.12

Have more questions? Submit a request
Please sign in to leave a comment.