Applicable to:
- Plesk for Windows
Symptoms
-
When accessing Plesk, the following error appears in a browser:
PLESK_INFO: Service Unavailable.
HTTP Error 503. The service is unavailable. -
The "PleskControlPanel" application pool at IIS Manager > SERVERNAME > Application Pools is stopped. After starting it manually, the application pool stops on the next attempt to open Plesk in a browser.
-
The following error message appears in the Event Viewer Application log (Windows Logs):
PLESK_INFO: The worker process for application pool 'PleskControlPanel' encountered an error
'Cannot read configuration file due to insufficient permissions
' trying to read configuration data from file '?\C:\inetpub\temp\apppools\PleskControlPanel\PleskControlPanel.config', line number '0'.
The data field contains the error code.
PLESK_INFO: The worker process for application pool 'PleskControlPanel' encountered an error
'Cannot read configuration file
' trying to read configuration data from file '\\?\<EMPTY>', line number '0'.
The data field contains the error code.
Cause
Plesk configuration file PleskControlPanel.config located at C:\inetpub\temp\appPools\PleskControlPanel is corrupted.
Resolution
-
Connect to the Plesk server via RDP.
-
Rename the PleskControlPanel.config file located at C:\inetpub\temp\appPools\PleskControlPanel. This file will be automatically generated on the next attempt to open Plesk.
-
Start Plesk Reconfigurator at Windows Start > All Programs > Plesk.
-
In Plesk Reconfigurator, click Repair Plesk Installation > select Check Plesk Services > click Check.
-
Restart IIS using the following command in a command prompt:
C:\> iisreset /restart
- Open Plesk in a web-bowser.
Comments
2 comments
Hi,
unfortunately, I could not solve the problem with above method.
Please Help me.
The worker process for application pool '****.com(domain)(4.0)(pool)' encountered an error 'Cannot read configuration file
' trying to read configuration data from file '\\?\<EMPTY>', line number '0'. The data field contains the error code.
Hi Ehsan,
This article is applicable if the issue occurs with Plesk site itself. However, in your case, the issue is related to a particular website.
Please check the following article: https://support.plesk.com/hc/en-us/articles/213924885
Hope that helps!
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