Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
- No backup operations are running
-
Cannot activate domain in Plesk:
PLESK_ERROR: Error: The domain or website example.com cannot be activated because it was disabled by your hosting provider.
OR
PLESK_ERROR: Error: The domain or website example.com cannot be activated because it was suspended by your hosting provider.
-
It may not be possible to activate it via CLI as well:
# plesk bin domain --on example.com
An error occurred during turning domain on/off: The domain is suspended because the subscription is still suspended.
Cause
Unclear.
Can be related to the bug PPPM-12610.
Resolution
-
Activate domain via CLI, if you did not try it yet:
# plesk bin domain --on example.com
If the solution above did not help:
activate domain in Plesk database
-
Back up Plesk database
-
Connect to Plesk database
-
Set domain status to active:
MYSQL_LIN: mysql> update domains set status = 0 where name='example.com';
-
Set webspace status to active:
MYSQL_LIN: mysql> update domains set webspace_status=0 where name='example.com';
-
To activate domain aliases, find suspended ones and activate them using the value of
dom_id
:MYSQL_LIN: mysql> select dom_id,displayName from domain_aliases where status!=0;
+--------+-------------+
| dom_id | displayName |
+--------+-------------+
| 40 | example.net |
+--------+-------------+
mysql> update domain_aliases set status=0 where status=2 and dom_id=40; - Log in to Plesk
- Go to Domains > example.com. Suspend and activate the domain to ensure the issue got fixed.
For Domain Aliases:
# update domain_aliases set status = 0 where name='example.com';
Comments
4 comments
Hi,
this problem occurs every 2-3 weeks on my plesk installation. Is there any way to resolve the cause? Is it a good idea to write a cronjob that checks for domain status and webspace_status and/or updates regularly?
Hey,
It might be that the subscription in your Plesk overuses its resource limits and overuse is not allowed by policy. Because of this, the subscription is automatically suspended if the resource usage exceeds the limit values.
See this KB article for details:
https://support.plesk.com/hc/en-us/articles/115000840865
same problem to me since i moved from cpanel and setup the db.
even the subscription is not exist, its connected maybe to external, because the subscription i have have enough resources.
Hello @jnasser, Please submit a ticket to Plesk Support https://support.plesk.com/hc/en-us to investigate the issue further.
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