An attempt to update Wordpress produce permission error

Created:

2016-11-16 12:46:28 UTC

Modified:

2017-06-19 05:08:55 UTC

0

Was this article helpful?


Have more questions?

Submit a request

An attempt to update Wordpress produce permission error

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

An attempt to update Wordpress produce permission error:

Can't create folders or files.

Cause

Wrong permissions on Worpress installation files.

Resolution

By default the Wordpress APS application is installed with permissions 646 for files and 757 for folders. You can use the script which sets the permissions for Worpress installation to default:

#!/bin/bash 
#Path to Wordpress installation
wp_path="$1"
#Restore permissions to the default
find $wp_path -type d -exec chmod 757 {} \\;
find $wp_path -type f -exec chmod 646 {} \\;

Create the script on your server, add the executable permissions, and execute it giving the path to WP installation as a parameter:

vi fix_wordpress
chmod +x fix_wordpress
./fix_wordpress /var/www/vhosts/domain.com/worpress

More information regarding Wordpress permissions could be found in Wordpress Codex .

Have more questions? Submit a request
Please sign in to leave a comment.