PHP with FastCGI does not function in Plesk for CloudLinux after migration from cPanel on some sites

Refers to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:46:05 UTC

Modified:

2016-12-21 19:10:00 UTC

0

Was this article helpful?


Have more questions?

Submit a request

PHP with FastCGI does not function in Plesk for CloudLinux after migration from cPanel on some sites

Symptoms

After completing a migration the following error is displayed in web browser (PHP with FastCGI):

HTTP/1.1 500 Internal Server Error

However PHP is run well if it is switched to Apache module instead of FastCGI.

PHP with FastCGI works properly for some websites, but it doesn't for other sites.

Also the following error is appeared in suexec log file:

# tailf /var/log/httpd/suexec_log
...
[2014-10-07 06:08:41]: SecureLVE jail error Invalid regexps: no match for path to base home directory

Cause

This happenes when package "cagefs" is installed and enabled for all users.

Resolution

As a workaround CageFS can be turned off on the server.

  1. Check whether "cagefs" package is installed:

    # rpm -qa | grep 'cagefs'
    cagefs-5.2-36.3.el6.cloudlinux.x86_64
    cagefs-safebin-5.2-36.3.el6.cloudlinux.x86_64
  2. Disable CageFS for all users:

    # cagefsctl --disable-all

After that PHP with FastCGI should function OK.

Have more questions? Submit a request
Please sign in to leave a comment.