How to upgrade MySQL from 5.1 to 5.5 on Linux?

Follow

Comments

4 comments

  • Avatar
    Greg Sims

    I am running RHEL 6.  This process will not work using sudo -- you must be root.  Issue "sudo su" prior to issuing the commands above.

  • Avatar
    Anton Maslov

    @Greg,

     

    In general articles are written considering that all the commands will be invoked with root privileges since we do not know how exactly our customers work on the server (under root or not).

    Thank you for the comment - I believe it will be useful for other Pleskians :)

     

  • Avatar
    David Eliseu

    Do not working, or better do not upgrading, getting:

    Loaded plugins: presto
    Setting up Upgrade Process
    No Packages marked for Update

    But, sql server are on 5.1.73

  • Avatar
    Bulat Tsydenov

    @David, Hi! 

    As I understand you receive that output when running `yum upgrade mysql`

    Please, provide me with the following information:

    - OS version

    - the output of `yum repolist` command

    - the output of `rpm -qa | grep mysql` command

Please sign in to leave a comment.

Have more questions? Submit a request