Unable to upgrade/install Plesk 12: package it is not installable

Refers to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:44:55 UTC

Modified:

2016-12-21 19:07:22 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to upgrade/install Plesk 12: package it is not installable

Symptoms

Plesk 12 installation or upgrade fails with an error like:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
apache2 : Depends: apache2.2-common (= 2.2.22-13+deb7u3) but it is not going to be installed
apache2-mpm-prefork : Depends: apache2.2-common (= 2.2.22-13+deb7u3) but it is not going to be installed
Depends: apache2.2-bin (= 2.2.22-13+deb7u3) but it is not going to be installed
mysql-server : Depends: mysql-server-5.5 but it is not going to be installed
plesk-base : Depends: sw-engine (>= 2.13.8) but it is not going to be installed
plesk-core : Depends: libcurl3 (>= 7.16.2) but it is not going to be installed
Depends: libxslt1.1 (>= 1.1.25) but it is not installable
Depends: libmyodbc but it is not installable
Depends: pigz but it is not installable
Depends: gawk but it is not installable
Depends: sharutils but it is not installable
Depends: rsync but it is not installable
Depends: zip but it is not installable
Depends: curl but it is not going to be installed
Depends: db4.8-util but it is not installable
Depends: xsltproc but it is not installable
Depends: libtimedate-perl but it is not installable

Cause

Non standard repositories enabled in /etc/apt/sources.list file, a sa result system cannot resolved all the dependencies properly.

Resolution

Try to update/install Plesk with a default repositories. Replace data in source.list file like below:

For Ubuntu 14.04 LTS :

# cat /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu trusty main restricted universe
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe
deb http://security.ubuntu.com/ubuntu trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu trusty partner

For Ubuntu 12.04.4 LTS :

# cat /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu precise main restricted universe
deb http://archive.ubuntu.com/ubuntu precise-updates main restricted universe
deb http://security.ubuntu.com/ubuntu precise-security main restricted universe
deb http://archive.canonical.com/ubuntu precise partner
Have more questions? Submit a request
Please sign in to leave a comment.