Unable to upgrade Plesk 12.0 to 12.5 on RHEL 5: shm conflicts with psa

Created:

2016-11-16 12:44:51 UTC

Modified:

2017-08-08 13:30:29 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to upgrade Plesk 12.0 to 12.5 on RHEL 5: shm conflicts with psa

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Unable to upgrade Plesk 12.0 to 12.5:

Attempt to remove 'shm' to resolve conflict has failed
shm-12.5.30-rhel5.build1205150826.19.x86_64 from PLESK_12_5_30-dist has depsolving problems
--> shm conflicts with psa
psa-12.5.30-rhel5.build1205150826.19.x86_64 from PLESK_12_5_30-dist has depsolving problems
--> psa conflicts with shm
Exception: Failed to solve dependencies:
shm conflicts with psa
psa conflicts with shm

Cause

plesk-service-node-agent package is installed, but not required in Plesk 12.0 distribution.In Plesk 12.5 this package requires shm that conflicts with Plesk.

Resolution

  1. Find exact package name:

    # rpm -qa | grep plesk-service-node-agent
  2. Remove the package:

    # rpm -e plesk-service-node-agent-12.0.18-rhel5.build1200140606.15
  3. Try to upgrade Plesk again

    # /usr/local/psa/admin/bin/autoinstaller
Have more questions? Submit a request
Please sign in to leave a comment.