Can not switch to SmarterMail or create mailbox - Failed to log in.

Created:

2016-11-16 12:44:34 UTC

Modified:

2017-04-24 12:13:20 UTC

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Can not switch to SmarterMail or create mailbox - Failed to log in.

Applicable to:

  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

The following error is thrown upon attempt to switch from MailEnable to SmarterMail:

Error: Unable to set SmarterMail Server 10.7.4787 as the default Mail Server: defpackagemng failed: Execute mchk.exe failed with error code 1: Can't obtain mail box forwarding info.
Domain: domain.tld [domain.tld].
Mail name: sales.
Reason: Failed to log in
....
(Error code 1)

The following error is thrown upon attempt to create mailbox:

Error: Unable to update the mail account properties:mailmng failed: Can't open domain.
Domain: domain.tld [domain.tld].
Reason: Failed to log in.
....
(Error code 1)

Cause

Integration between Plesk and Smartermail is broken.

Resolution

  1. Ensure that no other services are listening on the 9998 port:

    "%windir%\\System32\\inetsrv\\appcmd" list site | findstr 9998
    SITE "Smartermail" (id:12,bindings:http/*:9998:,state:Started)
    SITE "webmail(SmarterMail)" (id:13,bindings:http/192.168.0.67:9998:,state:Started)
  2. Remove the 9998 port from other website's bindings in IIS. In the example above it is webmail(SmarterMail).

  3. Ensure that correct login and password are set on the Home > Tools & Settings > Plesk Components > SmarterMail Server page.

  4. Reset password for SmarterMail if necessary. Refer to the following article on how to reset password - How to reset password for SmarterMail

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