Unable to create a new customer or access APS Application Vault

Refers to:

  • Plesk 11.5 for Windows

Created:

2016-11-16 12:43:55 UTC

Modified:

2016-12-21 19:05:00 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to create a new customer or access APS Application Vault

Symptoms

Unable to create a customer/subscription or to get access to APS Application Vault in Plesk the following error message is displayed:

[MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on '127.0.0.1' (10061)ODBC error #HY000:
File
aps_php.php
...

Cause

'apsc' database does not present on the server.

Resolution

Create the database with the following commands:

"%plesk_bin%"\\mysqlmng_adm.exe --create-database --database=apsc

"%plesk_bin%"\\mysqlmng_adm.exe --add-user --database=apsc --new-user-login=apsc --new-user-password=<APSC_USER_PASSWORD> --allowed-host=localhost

"%plesk_dir%"\\MySQL\\bin\\mysql.exe -P8306 -uapsc -p<APSC_USER_PASSWORD> apsc < "%plesk_dir%"\\admin\\db\\apsc\\dbschema-mysql.sql

"%plesk_bin%"\\php.exe -q -dauto_prepend_file="" -c "%plesk_dir%\\admin\\php.ini" "%plesk_dir%\\admin\\plib\\scripts\\register_apsc_database.php" --register -host 127.0.0.1 -port 8306 -database apsc -login apsc -password <APSC_USER_PASSWORD>
Have more questions? Submit a request
Please sign in to leave a comment.