Mails are not receiving from some of external domains: COM Pickup Event pleskmemta.PleskMEMTA removed message

Created:

2016-11-16 12:43:44 UTC

Modified:

2017-04-25 10:34:09 UTC

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Mails are not receiving from some of external domains: COM Pickup Event pleskmemta.PleskMEMTA removed message

Applicable to:

  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

Unable to receive an email despite of the fact email is delivered to the server.

The following entries correspond to the successful email delivery to the server:

04/25/17 11:10:25    ME-I0149: [1448] E991458F76F24C6BB3903479118CAC6A.MAI was received successfully and delivery thread was initiated

MailEnable Emails Tracking utility in Servers->localhost->System->Diagnose shows:

Trace: Tracing message with Message ID [E991458F76F24C6BB3903479118CAC6A.MAI] from the SMTP Inbound Queue
Result: [E991458F76F24C6BB3903479118CAC6A.MAI] was not routed from the SMTP inbound message queue by the local MTA Service. Below are relevant log details:
MTA Debug log matches:
04/25/17 11:10:25    Processing file E991458F76F24C6BB3903479118CAC6A.MAI from queue SMTP
04/25/17 11:10:25    ME-MTA-INFO : Routing message (E991458F76F24C6BB3903479118CAC6A.MAI) from (SMTP) to 1 recipient(s).
04/25/17 11:10:25    MTADeliverMessage::Executing external COM event pleskmemta.PleskMEMTA with message E991458F76F24C6BB3903479118CAC6A.MAI from SMTP queue

The following line is traced from MTA logs:

04/25/17 11:10:25 MTADeliverMessage:: COM Pickup Event pleskmemta.PleskMEMTA removed message E991458F76F24C6BB3903479118CAC6A.MAI.

Cause

The issue is related to DomainKeys spam protection feature, which is enabled in Plesk, by default. Mail may be deleted by this feature. DomainKeys module verifies mails only if sender is not local and receiver is local.

Resolution

DNS should be checked on the external server side: system administrator of the external (sender) server has to setup DNS correctly so that they comply with DomainKeys.

If Plesk administrator trusts the sender of the external server and is sure that messages from this server should not be declined, it is required to turn off DomainKeys for incoming messages: Plesk > Tools & Settings > Mail server settings uncheck Verify incoming mail

If this did not help do the following:

  1. Disable (set value to 0) Plesk MTA in HKEY_LOCAL_MACHINE\\SOFTWARE\\Mail Enable\\Mail Enable\\Agents\\MTA\\Pickup Event Enabled

  2. Restart MTA

  3. Send message again.

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