Mails are not receiving from some of external domains: COM Pickup Event pleskmemta.PleskMEMTA removed message

Refers to:

  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Created:

2016-11-16 12:43:44 UTC

Modified:

2016-12-21 19:04:36 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Mails are not receiving from some of external domains: COM Pickup Event pleskmemta.PleskMEMTA removed message

Symptoms

Unable to receive an email despite of the fact email is delivered to the server.

Following line is traced from mail logs which shows that mail is deleted by Plesk :

11/20/14 15:36:28       MTADeliverMessage:: COM Pickup Event pleskmemta.PleskMEMTA removed message CEBEF8C539D74ACF8C36BD8A8A848E6F.MAI

Cause

The issue is related to DomainKeys spam protection feature, which is enabled in Plesk, by default. Mail may be deleted by this feature. DomainKeys module verifies mails only if sender is not local and receiver is local.

Resolution

To fix the issue, go to Plesk > Tools & Settings > Mail server settings and uncheck Verify incoming mail option in DomainKeys spam protection sector.

If this did not help do the following:

  1. Disable (set value to 0) Plesk MTA in HKEY_LOCAL_MACHINE\\SOFTWARE\\Mail Enable\\Mail Enable\\Agents\\MTA\\Pickup Event Enabled

  2. Restart MTA

  3. Send message again.

Have more questions? Submit a request
Please sign in to leave a comment.