Snapshot restoration fails

Created:

2016-11-16 12:43:11 UTC

Modified:

2017-05-15 18:24:13 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Snapshot restoration fails

Applicable to:

  • Web Presence Builder 12.0 for Linux
  • Web Presence Builder 12.0 for Windows
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Web Presence Builder 11.5 for Linux
  • Plesk 12.5 for Windows

Symptoms

Restoration of a snapshot fails with the following error:

Unexpected server behavior. For details, see the product's log files.
Some errors were written to log. Please contact to administrator.

In /usr/local/psa/admin/logs/sitebuilder.log the following error appears:

2014-04-15T22:31:13-04:00       [EMERG] /sitebuilder/JsonApi/   SB_Site_Snapshot_Exception: invalidSnapshot
file: /usr/local/sb/include/SB/Site/Snapshot.php
line: 258
code: 0
trace: #0 /usr/local/sb/include/SB/Site/Snapshot.php(328): SB_Site_Snapshot->_decode('/usr/local/sb/t...')
#1 /usr/local/sb/include/SB/Facade/Service/Site.php(806): SB_Site_Snapshot->restore(0, false)
#2 [internal function]: SB_Facade_Service_Site->restoreSiteSnapshot('85907705-5c2d-0...', 0, false)

After uploading a valid snapshot from test environment the restoration fails as well.

Cause

This is software issue PPPM-1574 .

Workaround

As a workaround replace fixed Target.php from attachment with original one which is located in /usr/local/sb/include/SB/Extension/PP/Target.php .

# cd ~
# wget https://support.plesk.com/hc/article_attachments/115004351705/hotfixpppm1574.zip
# unzip hotfixpppm1574.zip
# mv /usr/local/sb/include/SB/Extension/PP/Target.php /usr/local/sb/include/SB/Extension/PP/Target.php.orig
# mv ./Target.php /usr/local/sb/include/SB/Extension/PP/

Attachments:

Have more questions? Submit a request
Please sign in to leave a comment.