HOW TO: Fix broken locale in Plesk

Refers to:

  • Plesk 10.4 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows

Created:

2016-11-16 12:41:53 UTC

Modified:

2016-12-21 19:00:02 UTC

0

Was this article helpful?


Have more questions?

Submit a request

HOW TO: Fix broken locale in Plesk

Symptoms

After upgrade/update/restore Plesk GUI is messed-up.

Menu elements are displayed in square brackets, like this:

[[domains]]
[[customers]]

Cause

System locale is not being loaded due to database inconsistency or corruption of system files.

In case if Plesk version is 11.5, this could be also caused by a special option in the %plesk_dir%\\admin\\conf\\panel.ini :

; Show locale keys instead of localized string (values: off, on, long)
;showKeys = long

Resolution

  1. Check the following KB for solution: /en/213375709 .

    If the aforementioned KB doesn't help, please check steps 2 and 3 that are below.

  2. Make sure the following directories contain the necessary locales:

    C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\panel\\application\\resources\\languages

    C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\locale

    C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\locales

    If there is something missing:

    Get plesk-l10n.msi and plesk-locale-base-en-US.msi from the Plesk installation and extract files from a .msi file at the command line and copy them to the %plesk_dir% .

    For example, to extract files you would type:

    msiexec /a  C:\\Parallels\\PANEL-WIN_11.5.30\\dist-msi-Microsoft-2003-i386\\plesk-l10n.msi /qb TARGETDIR=DirectoryToExtractTo

    The destination directory does not need to exist prior to running this command.

  3. Make sure that option showKeys = long is not activated in panel.ini .

Have more questions? Submit a request
Please sign in to leave a comment.