Reseller account is getting suspended after upgrade to Plesk 12.5

Created:

2016-11-16 12:41:25 UTC

Modified:

2017-04-24 11:21:38 UTC

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Reseller account is getting suspended after upgrade to Plesk 12.5

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.5 for Windows

Symptoms

After upgrade from Plesk 12.0.18 to Plesk 12.5.30 a reseller account is getting suspended with no apparent reason (i.e, no resources overusing) by Plesk Daily Maintenance task.

This reseller account was converted from customer account some time ago before Plesk upgrade.

Cause

This is a software issue with internal ID PPP-17549 which has been fixed in Plesk 12.5 MU#3

Resolution

Install latest Plesk 12.5 micro-updates.

If upgrade is not possible, use the following workaround:

Since max_site value should be ignored for reseller set it to -1 for all such resellers:

  1. Create psa database backup:

    # mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` psa > psa_dump.sql
  2. Login to Plesk database:

    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa
  3. Find such values:

    mysql> select l.id, l.limit_name,l.value ,c.pname from Limits as l join clients as c on l.id=c.limits_id where c.type='reseller' and l.limit_name="max_site" and l.value <> -1;
  4. Set all such values to -1 :

    mysql> update Limits set value=-1 where id in (select perm_id from clients where type='reseller') and limit_name='max_site';
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