Error: Unable to start Parallels Products Installer.

Created:

2016-11-16 12:40:46 UTC

Modified:

2017-04-24 12:15:34 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Error: Unable to start Parallels Products Installer.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Symptoms

Plesk Control panel -> Tools and Settings -> Updates and Upgrades, it will fails with error:

Error: Unable to start Parallels Products Installer. The following error has occurred: Error running autoinstaller

From panel.log:

PHP Warning: DOMDocument::loadXML(): Start tag expected, '<' not found in Entity, line: 1; File: /opt/psa/admin/plib/CommonPanel/AutoInstaller/Response.php, Line: 28

Exception: PHP Warning: DOMDocument::loadXML(): Start tag expected, '<' not found in Entity, line: 1; File: /opt/psa/admin/plib/CommonPanel/AutoInstaller/Response.php, Line: 28

Cause

Autoinstaller binary has been replaced by installer script:

# file /opt/psa/admin/sbin/autoinstaller
/opt/psa/admin/sbin/autoinstaller: POSIX shell script, ASCII text executable

Resolution

To fix the issue, replace ' /opt/psa/admin/sbin/autoinstaller ' with actual autoinstaller:

# mv /opt/psa/admin/sbin/autoinstaller /opt/psa/admin/sbin/autoinstaller.bak
# cp /root/parallels_installer /opt/psa/admin/sbin/autoinstaller

# file /opt/psa/admin/sbin/autoinstaller
/opt/psa/admin/sbin/autoinstaller: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, BuildID[sha1]=0x1e1c033c2f9b68dfa2c7e26c294a3cc675b67001, stripped

After that you may rerun autoinstaller from the Plesk Panel Home page.

Have more questions? Submit a request
Please sign in to leave a comment.