Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
When opening webmail/domain in a browser, it returns one of the following errors:
-
Firefox:
CONFIG_TEXT: "Server not found. Firefox can't find the server at webmail.example.com"
-
IE:
CONFIG_TEXT: "Internet Explorer cannot display the webpage"
-
Chrome:
CONFIG_TEXT: "Oops! Google Chrome could not find webmail.example.com"
OR
CONFIG_TEXT: "ERR_NAME_NOT_RESOLVED"
OR
CONFIG_TEXT: "404 not found"
-
-
Let's Encrypt cannot be issued on the domain:
CONFIG_TEXT: Error: Could not issue a Let's Encrypt SSL/TLS certificate for example.com. Authorization for the domain failed.
<...>
Details:
Type: urn:acme:error:connection
Status: 400
Detail: Fetching http://example.com/.well-known/acme-challenge/cCMl-4ZDqnWT-DEADBEEFl0sl_z9KVN_Ghkc1f1pMpQ: Timeout during connect (likely firewall problem)
Cause
Webmail/domain does not resolve correctly in global DNS system because Plesk server is not set up to manage DNS.
Resolution
To verify the root cause, run the following commands in a command-line interface:
Note: the commands are identical on Windows, Linux and MacOS. The commands below are valid for webmail as well
-
First, test if domain can be resolved to an IP address in general:
C:\> nslookup example.com
Server: mydns.server.com
Address: 203.0.113.2
Non-authoritative answer:
Name: example.com
Address: 203.0.115.20Output explanation:
-
Server and Address represent hostname and address of the server that provides response for the query sent by command
nslookup
; - Name and Address(es) are the domain name which IP address is being queried and the IP address that was provided by the server as a response.
However, if the following output is seen instead, it means that the domain does not resolve properly:
C:\> nslookup webmail.example.com
Server: mydns.server.com
Address: 203.0.113.2
*** UnKnown can't find example.com: No response from server -
Server and Address represent hostname and address of the server that provides response for the query sent by command
-
Next, check if DNS service on the server with Plesk contains proper record for the domain:
C:\> nslookup webmail.example.com 203.0.115.20 <---- IP address of the server with Plesk
Server: UnKnown
Address: 203.0.115.20
Name: webmail.example.com
Address: 203.0.115.20
If the first command does not return anything or returns a wrong IP address, and the second command returns valid records, then Plesk server is not serving the DNS zone for a domain.
There are two options to resolve the issue:
-
Set Plesk server to be nameserver of the domain: How to use DNS with a Plesk server;
-
Add a respective A-record on a registrar/3rd-party DNS side.
Note: a similar issue can be observed for other DNS records like TXT, MX, CNAME and etc.
Comments
3 comments
And what if the first command and the second command BOTH return valid records, but webmail still doesn't work?
Hi Edward Parker,
My first question: Is the IP returned by the commands pointing to the right server?
If so, it is another cause then as this article is for the case where the webmail doesn't resolve.
I am using Plesk for my redirected subdomain. I just need to set up webmail for my subdomain without redirecting my domain.
I did the mentioned task and everything looks ok. Because I have a different IP address for my domain in comparison to my subdomain. But in any case, there is no webmail available. But in the control panel under the log file, it says that the email was sent but there is no email received from the other side.
Any assistance regarding this issue.
Many thanks
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