Cannot restore individual files/folders: files list is empty.

Created:

2016-11-16 12:39:23 UTC

Modified:

2017-08-08 13:29:09 UTC

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Cannot restore individual files/folders: files list is empty.

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

  • When trying to restore particular files from multi-volume backup, it shows an empty files list.
  • Customer have '@' in login name.

Cause

Content index used for selective restore is built incorrectly for multi-volume backups of subscriptions owned by customers with '@' in login.

This is Plesk internal issue with id #PPPM-3532 , which is planned to be fixed in future Plesk updates.

Workaround

For existing backups:

  1. Move subscription backups on filesystem from client to admin (It does not affect GUI and statistics). for example:

    # mv /var/lib/psa/dumps/clients/customer@domain.tld/domains/domain.tld/ /var/lib/psa/dumps/domains/domain.tld/
  2. Remove the existing index files:

    # find /var/lib/psa/dumps/domains/domain.tld/ -name webcontent_index | xargs rm -f
  3. Go to subscription backup manager and restore the files. First access to files list may be slow due to the index recreation. Please note, that all new backups will be created in the original location (under client)

For new backups, there are two options:

  1. Avoid creating customer accounts with '@' in login.

  2. Disable creating multi-volume backups for customers with "@" in login.

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