Symptoms
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Extensions is not available in Plesk with:
Internal server error Retry
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The following message if found in
/var/log/plesk/panel.log
:Could not resolve host: ext.plesk.com
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It might be not possible to retrieve additional Plesk license in Tools & Settings > License Management with the following error:
cURL cannot communicate with license server https://ka.plesk.com/xmlrpc (): Couldn't resolve host name(6)
Cause
Corrupted Plesk extension catalog cache.
Resolution
Warning: Before applying this solution to a retrieving license error, restart sw-engine
first and check if the issue is resolved. Only try to remove the cache if that doesn't work. Confirmation that the license issue is related to the cache is necessary because it looks strange.
Note: Update the article accordingly after checking the warning above.
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Connect to the server via SSH;
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Remove cache files:
# rm -rf /usr/local/psa/var/cache/https*
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Remove cache records from Plesk database:
# plesk db "delete from PersistentCache where events like '%catalog%'"
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Restart Plesk service:
# service sw-engine restart
Comments
1 comment
Phew - good fix and worked without issues.
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