Symptoms
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The following error appears under Plesk > Monitoring after configuring 360 Monitoring:
CONFIG_TEXT: An unexpected error occurred
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The following error is logged in
/var/log/plesk/panel.log
:CONFIG_TEXT: ERR [panel] Unable to Connect to ssl://api.monitoring360.io:443. Error #0: :
0: /usr/local/psa/admin/plib/modules/monitoring/library/Http/HttpClient.php:147
PleskExt\Monitoring\Http\HttpClient->request()
1: /usr/local/psa/admin/plib/modules/monitoring/library/CloudApi/Monitoring360/Monitoring360ApiClient.php:105
PleskExt\Monitoring\CloudApi\Monitoring360\Monitoring360ApiClient->getServerNotifications(string '62...1c')
2: /usr/local/psa/admin/plib/modules/monitoring/library/CloudApi/Monitoring360/Monitoring360ApiBroker.php:161
PleskExt\Monitoring\CloudApi\Monitoring360\Monitoring360ApiBroker->getServerNotifications(string '62...1c')
3: /usr/local/psa/admin/plib/modules/monitoring/scripts/cloud-alerts.php:27
Cause
Outdated CA on the server.
Resolution
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Connect to the server via SSH
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Update certificate authority information:
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Debian-based (Debian/Ubuntu):
# update-ca-certificates
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RHEL-based (RHEL/CentOS/AlmaLinux):
# yum update ca-certificates
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Comments
2 comments
Thanks for this writeup.
But how to solve this on windows plesk ? the above solution only apply to linux plesk.
Am running plesk on windows server and am experiencing this problem.
Thanks
Hi ADEWALE SOLIU.
Windows servers are not affected by this, please take a look into this issue: https://support.plesk.com/hc/en-us/articles/13786411637655
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