Applicable to:
- Plesk for Linux
Symptoms
- Plesk Obsidian running on a Linux-based server and using the Amazon S3 Backup extension for Plesk
-
Backup from Plesk to AWS S3 fails with an error that is similar to the following:
CONFIG_TEXT: Unable to create the remote backup: Transport error: Extension transport: ext://s3-backup/server/: 100 Continue
-
With enabled debug mode in Plesk, the following error appears in the
/var/log/plesk/PMM/backup-202301010000/backup.log
:CONFIG_TEXT: S3Exception caught: Error executing "UploadPart" on "https://w3m7.la.idrivee2-18.com/platinum-server/backup_202301010000.tar?uploadId=m6b0p2k6-747b-4153-a0a3-80b565b3b4b5&partNumber=792"; AWS HTTP error: cURL error 56: TCP connection reset by peer (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) (server): 100 Continue -
DEBUG (7) [extension/s3-backup]: Rethrow exception because total maximum number of failures exceeded.
DEBUG (7) [extension/s3-backup]: uploadPart error: 100 Continue
DEBUG (7) [extension/s3-backup]: abortMultipartUpload request:
Cause
Intermittent networking issues between the Plesk server and AWS s3 storage are preventing the backup upload process from finishing successfully.
Resolution
- Edit the /usr/local/psa/admin/conf/panel.ini
-
Set the following values in the
[ext-s3-backup]
section of thepanel.ini
file (create the section if necessary):CONFIG_TEXT: [ext-s3-backup]
MaxResumeAttempts = 30
MaxResumeFailures = 30
These values will increase the number of possible resume attempts that the extension will make while uploading the backup. You may increase the value for the number of allowed attempts further if necessary.
Comments
2 comments
Worked great, thank you!
We encountered a similar issue with S3 on Scaleway. When a communication error occurs, the backup process hangs indefinitely. In one case, we experienced a 20-hour wait for a 1GB transfer, and it still didn’t complete.
The most concerning part is that a stale backup prevents any subsequent backup from starting successfully. To resolve this, you can either log in via SSH and terminate the hanging process with the following command:
/usr/bin/sw-engine -c /opt/psa/admin/conf/php.ini /opt/psa/admin/sbin/backup_restore_helper --extension-transport ext://s3-backup/server/ -operation open-write
Alternatively, if you're limited to the web interface, you’ll need to reboot the entire host to clear the issue.
I also attempted to adjust the following settings in
panel.ini
:[ext-s3-backup]
; https://talk.plesk.com/threads/amazon-s3-backup-connecting-to-scaleway-object-storage.357132/
RegionForCustomEndpoint = fr-par
; https://talk.plesk.com/threads/server-back-ups-getting-stuck.364947/
ConnectionTimeout = 120
MaxResumeAttempts = 20
MaxResumeFailures = 60
However, these changes had no effect on resolving the issue.
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