Symptoms
The following error is displayed when trying to issue a Digicert certificate for a domain:
PLESK_INFO: Issuing the certificate. The order is taking too long to process. It seems that something went wrong. Please contact your administrator or Plesk support.
With enabled debug mode the following messages can be found in /var/log/panel.log:
PLESK_INFO: [stream:protected] => Digicert\Api\Stream Object
( [body:Digicert\Api\Stream:private] =>
{"order_id":"309745682","order_status":"pending","order_name_scope":"fqdn","order_dcv_method":"http-token","dns_name_validations":[{"status":"approved","dns_names":["example.com"],"base_domain":"example.com"},{"status":"approved","dns_names":["www.example.com"],"base_domain":"example.com"}]}
[2022-11-24 13:13:34.137] 123381:637f5fe96dc8d ERR [extension/sslit] Error happened while certificate processing : The order is taking too long to process. It seems that something went wrong. Please contact your administrator or Plesk support.
[2022-11-24 13:13:34.138] 123381:637f5fe96dc8d INFO [extension/sslit] Check notifications which already sent in interval since 1669205614 to 1669292014.
Cause
DNS CAA record is absent for the domain example.com
Resolution
Add the digicert.com CAA record for the example.com domain:
How to add a CAA DNS record on a domain in Plesk?
An example of CAA records may be found in the following Digicert documentation article: https://docs.digicert.com/en/certcentral/manage-certificates/dns-caa-resource-record-check.html
Comments
0 comments
Please sign in to leave a comment.