Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
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Failed to protect domain in SpamExperts extension for Plesk, the following error appears
PLESK_ERROR: Unable to add to SpamExperts: Failed to add the domain 'example.com' into the spamfilter
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With enabled debug logging in the log file
/var/log/plesk/panel.log
the following error message can be found:PLESK_INFO: Modules_SpamexpertsExtension_SpamFilter_Api::checkDomain: Domain protection check request
INFO [extension/spamexperts-extension] SpamFilter API response: ERROR: The domain 'example.com' does not belong to the admin 'plesk_1234568_1'. -
MX records are pointing to Spamexperts:
# host example.com
example.com has address 203.0.113.2
example.com mail is handled by 30 lastmx.spamexperts.net.
example.com mail is handled by 10 mx.spamexperts.com.
example.com mail is handled by 5 mail.example.com.
example.com mail is handled by 20 fallbackmx.spamexperts.eu.
Cause
Issue is on SpamExperts side: The error indicates that the domain belongs to a different account on SpamExpert side. It may happen if the domain was protected with SpamExpert in past (with different SpamExpert license, for example) and the domain is still linked to another account (old one) on SpamExpert side.
Resolution
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Go to Domains > example.com > DNS Settings
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Remove all MX records which are pointing to
*.spamexperts.*
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Add new MX record
mail.example.com
for the domain in Domains > example.com > DNS settings > Add Record -
Protect domain again by selecting domain example.com in Extensions > My Extensions > SpamExperts Email Security > Domains and click Protect
Note: If solution above does not help, contact SpamExperts support for assistance using the form in the extension: Extensions > SpamExpert Email Security > Support
Comments
1 comment
Doesnt work and the SpamExperts support verifyied that the domain is not "stuck" in their system.
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