Applicable to:
- Plesk for Linux
Symptoms
-
Plesk is unresponsive and may say the license is expired
-
Plesk shows the following error
ERR [1] Token validation failed: Can not connect to 'ka.plesk.com' (6:6). Please check connection to 'ka.plesk.com' or contact Plesk support: <a href='https://www.plesk.com/support/' target='_blank'>https://www.plesk.com/support/</a>.; ; KV network error (ka.plesk.com: cURL cannot communicate with license server https://ka.plesk.com/jsonrest/pkp/20/verify-key (): Couldn't resolve host name(6)
-
Retrieving the license on the command line fails with one of these messages
ERR [panel] KeyUpdate Result code: 2 Unspecified error
ERR [panel] KeyUpdate Result desc: License key is not prolongated yetERR (3): KeyUpdate Result code: 2 Network failure
ERR (3): KeyUpdate Result desc: Couldn't resolve host name -
ka.plesk.com
can't be resolved by some of the serves' DNS resolvers:# dig ka.plesk.com @203.0.112.2
...
;; connection timed out; no servers could be reached
Cause
DNS server misconfiguration.
Resolution
-
Resolve the DNS server issue with the hosting provider, or change the system's DNS resolvers
-
Connect to the server via SSH and reinstall license key manually
# plesk bin license --install A00000-A00000-A00000-A00000-A00000
Comments
4 comments
I had the same problem:
[root@plesk ~]# dig ka.plesk.com @8.8.8.8
; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.15 <<>> ka.plesk.com @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10616
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;ka.plesk.com. IN A
;; ANSWER SECTION:
ka.plesk.com. 82 IN A 195.214.233.81
ka.plesk.com. 82 IN A 195.214.233.82
ka.plesk.com. 82 IN A 195.214.233.80
;; Query time: 18 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Nov 04 12:40:34 GMT 2023
;; MSG SIZE rcvd: 89
[root@plesk ~]# telnet ka.plesk.com 443
Trying 195.214.233.82...
Connected to ka.plesk.com.
Escape character is '^]'.
But when I tried to update the license it failed with cannot contact server. I had to manually install the license key. Nothing was being blocked through the firewall.....Maybe a problem with the license server?
This fixed its self. It must have been a problem at Plesk's side with the li9cense server.
In my installation nothing solved itself.
Since around one year each month my website is indicated as insecure/not trusted, my emails will not be sent via gmail client etc.
Such a system must run and run and run. Nothing else. It did over a decade (even before being called obsidian). So I am not used to manage something each week or month. We have bugs enough in software systems. When somebody implements such license things they should be design defensively. Breaking the trust of my customers by not more updating letsencrypt etc. seems to be a more aggressive design to me. I am not very satisfied with this looking for any repair here on one summerday after the other.
Michael Gellner This article describes an error that comes from the hosting provider. If you've already checked with them and believe it's in the system, please create a ticket with us and we'll be happy to check.
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