Applicable to:
- Plesk for Linux
Symptoms
-
A domain example.com uses the remote mail server;
-
Mail service is disabled in Domains > example.com > Mail Settings;
-
When email messages are sent to this domain from mailbox located on the same server, messages are bounced with the following error in
/var/log/maillog
:CONFIG_TEXT: postfix/qmgr[20813]: 408755E04C2: from=<jdoe@example.org>, size=635, nrcpt=1 (queue active)
postfix/smtp[19079]: 408755E04C2: to=<jdoe@example.com>, relay=none, delay=0.14, delays=0.14/0/0/0, dsn=5.4.6, status=bounced (mail for example.com loops back to myself) -
MX record of the domain
example.com
cannot be resolved by default DNS server and its A record points to Plesk server:# host -t MX example.com
example.com has no MX record
# host example.com
example.com has address 192.0.2.2
# hostname -I
192.0.2.2 -
Correct MX record is returned if a different DNS server is specified:
# host -t MX example.com 8.8.8.8
Using domain server:
Name: 8.8.8.8
Address: 8.8.8.8#53
Aliases:
example.com mail is handled by 10 externalmail.example.com.
Cause
Default DNS server returns incorrect answers if the affected domain is queried, as a result, Postfix tries to connect to itself.
Resolution
-
Connect to the server via SSH
-
Change the DNS server (nameserver) in
/etc/resolv.conf
file to a valid DNS server, such as 1.1.1.1:# cat /etc/resolv.conf
nameserver 1.1.1.1Note: Remove localhost or 127.0.0.1 if it is configured as a nameserver in
/etc/resolv.conf
file.Note: If this file is managed by an external program, such as NetworkManager, or resolvconf, configuration of the respective program should be modified.
Comments
0 comments
Please sign in to leave a comment.