Applicable to:
- Plesk for Linux
Symptoms
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There are a lot of emails stuck in the mail queue shown in Plesk in Tools & Settings > Mail Server Settings > Mail queue.
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All stuck emails were sent to a certain domain example.com.
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Both automatic connection by the mail server and the manual connection to the receiving mail server fails:
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Automatic connection by the mail server - the following error is found in the file
/var/log/maillog
:CONFIG_TEXT: hostname postfix/qmgr[7584]: 0CEFF7E685: removed
hostname postfix/qmgr[7584]: 99B1A7E666: from=jdoe@example.net, size=705, nrcpt=1 (queue active)
hostname postfix/qmgr[7584]: C9B817E66C: from=jdoe@example.net, size=1219, nrcpt=1 (queue active)
hostname postfix/smtp[12133]: connect to mail.example.com[203.0.113.2]:25: Connection timed out
hostname postfix/smtp[12133]: 99B1A7E666: to=john@example.com, relay=none, delay=137241, delays=137121/0.01/120/0, dsn=4.4.1, status=deferred (connect to mail.example.com[203.0.113.2]:25: Connection timed out) -
Manual connection:
# telnet mail.example.com 25
Trying 203.0.113.2...
telnet: connect to address 203.0.113.2: Connection timed out
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Cause
Firewall configuration on the recipient mail server blocks connections from the Plesk server.
MX records list for the recipient domain contains outdated record(s).
Resolution
Contact the owners of the recipient domain example.com so they revise the MX records list to contain correct IP addresses and allow connections over port 25 on the firewalls of their mail servers.
Comments
3 comments
The issue is similar but it has nothing to do with the receivers firewall There are multiple receivers and none of their emails have had any prior issues receiving or sending emails. The server restarted and now 500+ emails stuck in the que. We have tried accessing via SSH and command line to force emails from the que to be delivered however nothing works.
Hello,
Brian Struzik
Did you find a solution to your problem.
I have the exact same problem.
A solution you might try is, go to:
Home > Tools & Settings > Server-wide mail settings > Settings
Limitations on outgoing email messages
The following limits are default. They can be overridden in each service plan and subscription. The limits do not work server-wide, but act as a template for the plans and subscriptions for which no custom limits were specified. Note that switching on the limitation of outgoing email messages can affect the mail server performance. Learn more about limiting outgoing mail
Disable this: Turn on limitations on outgoing email messages
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