Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
In Plesk Obsidian, the button from extension Export lists to CSV is not shown in menus:
- Subscriptions.
- Domains
- Resellers.
- Subscriptions > example.com > Mail > Email Addresses (or Domains > example.com > Mail Accounts).
Cause
This is Plesk extension bug EXTPLESK-2119 that is planned to be fixed in future extension updates.
Resolution
As a workaround:
-
Connect to the server via SSH
-
Back up the file
/usr/local/psa/admin/htdocs/modules/export-lists/global.js
# cp -a /usr/local/psa/admin/htdocs/modules/export-lists/global.js{,.back}
- Replace the file
/usr/local/psa/admin/htdocs/modules/export-lists/global.js
with the attached one.
# wget https://plesk.zendesk.com/hc/article_attachments/12377016646679/global.js
# mv global.js /usr/local/psa/admin/htdocs/modules/export-lists/global.js
- Connect to the server via RDP.
- Open PowerShell via Start > Windows PowerShell.
- Download the quick fix from the article attachments.
PS [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12
PS Invoke-WebRequest -URI
https://support.plesk.com/hc/en-us/article_attachments/360018422979/global.js -OutFile global.js
- Back up the file
%plesk_dir%admin\htdocs\modules\export-lists\global.js
by creating a copy.PS Move-Item -Path $env:plesk_dir\admin\htdocs\modules\export-lists\global.js $env:plesk_dir\admin\htdocs\modules\export-lists\global.js.bkp
- Replace the file
%plesk_dir%admin\htdocs\modules\export-lists\global.js
with the attached one.PS Move-Item -Path .\global.js $env:plesk_dir\admin\htdocs\modules\export-lists\
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