Applicable to:
- Plesk for Linux
Symptoms
-
System logs such as
/var/log/maillog
,/var/log/secure
or/var/log/messages
are empty and not populating. -
When activating Fail2Ban at Tools & Settings > IP Address Banning (Fail2Ban) > Settings, the operation is successful, but the option Enable intrusion detection is still disabled. The following error message appears in the service status:
# service fail2ban status
...
ERROR Failed during configuration: Have not found any log file for ssh jai
Cause
The system package rsyslog
which is responsible for logging is not installed on the server:
-
on CentOS/RHEL-based distributions
# rpm -qa | grep rsyslog
# -
on Debian/Ubuntu-based distributions
# dpkg -l | grep rsyslog
#
Note: The rsyslog
package does not come by default on AlmaLinux installations.
Resolution
-
Connect to the Plesk server via SSH.
-
Install the
rsyslog
package:-
on CentOS/RHEL-based distributions
# yum install rsyslog
or the command below, if DNF package manager is used:
# dnf install rsyslog
-
on Debian/Ubuntu-based distributions
# apt install rsyslog
-
-
Start the rsyslog service:
# systemctl start rsyslog
Comments
1 comment
We are experiencing this exact same scenario on a new AlmaLinux 9.1 server, but rsyslog is installed and running.
# rpm -qa | grep rsyslog
rsyslog-8.2102.0-105.el9.x86_64
# service fail2ban status
......
Process: 23936 ExecStart=/usr/bin/fail2ban-server -xf start (code=exited, status=255/EXCEPTION)
Main PID: 23936 (code=exited, status=255/EXCEPTION)
......
[23936]: ERROR Failed during configuration: Have not found any log file for [any log]
Any suggestions?
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