Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
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Migrating or restoring a subscription in Plesk fails
Incorrect DNS record values were specified: ns1.example.com. IN A 203.0.113.2: ('ttl' = '0')
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It's not possible to create a DNS record on Plesk with TTL value of 0
Value is invalid. It can be from 1 second to 2147483647 seconds.
Cause
This is caused by product issue PPPM-13621, where DNS records with TTL value of 0 can't be used.
Resolution
While a fix is released, the workaround is to manually set TTL to 0 after the records have been created.
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Log in to the source server over SSH
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Run this command to back up the Plesk database and reset all DNS records to the default TTL
# plesk db dump psa > /root/psa_pre_ttl_reset-$(date +%F_%T).sql && plesk db "UPDATE dns_recs SET ttl=DEFAULT(ttl) WHERE ttl=0"
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Re-sync the affected subscriptions on the target server
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Set the desired records back to 0 TTL directly on the Plesk database:
# plesk db "UPDATE dns_recs SET ttl=0 WHERE host LIKE '%affected_record%'"
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