Note: This article has the reference to the issue with the fix available:
- #PPPM-7824 "Support issue #PPPM-7824"
Fixed in:- Plesk Onyx 17.8 Release 17 April 2018
Symptoms
Unable to change a server IP address in Plesk Reconfigurator > Change server IP address if SmarterMail is used:
PLESK_ERROR: Unable to execute "C:\Program Files (x86)\Plesk\admin\bin\mailmng.exe" --assign-ports-to-ip --ip=203.0.113.2:
AssignPortToIP(203.0.113.2) failed: Error code -2. Error message: Unknown IP Address: 203.0.113.2.
at (SMSvcUtil::checkActionResult line 66)
at assignPortsToIP(203.0.113.2, false)(SmarterMail::Local::Provider::assignPortsToIP line 1223)
at assignPortsToIP(203.0.113.2, false)(SmarterMail::Local::Provider::assignPortsToIP line 838)
at execute console command --assign-ports-to-ip(vconsoleapp::start line 122)
at execute "C:\Program Files (x86)\Plesk\admin\bin\mailmng.exe" -assign-ports-to-ip "-ip=203.0.113.2"(vconsoleapp::run line 139)
Cause
This is a Plesk bug PPPM-7824 that will be fixed in future product updates.
Resolution
As a workaround, add a new IP in Windows Control Panel via Control Panel > Network and Internet > Network and Sharing Center > Change adapter settings, etc.
This way it will be possible to use the newly added IP in Plesk Reconfigurator.
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