Applicable to:
- Plesk for Linux
Symptoms
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Horde and Roundcube webmails are missing at
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Tools & Settings > Webmail
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Domains > example.com > Mail Settings:
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Both components are installed on the server at Tools & Settings > Upgrades & Updates > Add/Remove Components.
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The message "The component was not installed" is shown next the packages psa-horde and roundcube.
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Horde and Roundcube are missing in the Plesk database: when running the following command via SSH, the output is empty:
# plesk db "select * from Webmails;"
#
Cause
Database inconsistency.
Resolution
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Go to Tools & Settings > Server Components and click Refresh.
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Check if webmail is available.
If the solution above did not help, reinstall Horde and Roundcube via Plesk Installer:
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In Plesk, go to Tools & Settings > Updates and Upgrades.
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On the Updates and Upgrades page, open Add/Remove Components > click Webmail services > select Remove. Click Continue to begin uninstallation.
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Once the uninstallation process is completed, open again Add/Remove Components > select Webmail services for installation and click Continue button.
Comments
3 comments
I want to use Roundcube, and it seems the tables are missing in the database. When I remove roundcube, then reinstall roundcube as directed, I have the same problem: no tables, and "DATABASE ERROR: CONNECTION FAILED!" message when trying to open in the browser.
Got it working:
1. Remove roundcube as directed above.
2. Connect to the mysql database as root/admin/sa, and delete the roundcube@localhost user, and delete the roundcubeemail database.
3. Add roundcube back on Plesk (given above).
I have the same problem but I am not able to go to Updates section in plesk. I get an empty list there and can not see the packets like webmail. My mysql-DB crashed and I have to add the users I think there. Updating the existing "roundcube" user from an backup-db does not solve the problem. I only have Plesk Onyx v17.8.11_build1708180301.19 and no license for Obsidian. It seems I only can upgrade to Obsidian.
Error shown in Updates in plesk: (then available updates list and "all packets" list are empty)
Fehler: Paketliste konnte nicht abgerufen werden: 2021-01-05 14:35:01 INFO: pum is called with arguments: ['--list', '--repo-info', '--json'] 2021-01-05 14:35:03 ERROR: W:Failed to fetch http://autoinstall.plesk.com/PHP72_17/dists/jessie/all/binary-amd64/Packages 404 Not Found [IP: 195.181.175.54 80] , W:Failed to fetch http://autoinstall.plesk.com/PHP72_17/dists/jessie/all/binary-i386/Packages 404 Not Found [IP: 195.181.175.54 80] , W:Failed to fetch http://autoinstall.plesk.com/PHP73_17/dists/jessie/all/binary-amd64/Packages 404 Not Found [IP: 195.181.175.54 80] , W:Failed to fetch http://autoinstall.plesk.com/PHP73_17/dists/jessie/all/binary-i386/Packages 404 Not Found [IP: 195.181.175.54 80] , E:Some index files failed to download. They have been ignored, or old ones used instead. 2021-01-05 14:35:03 ERROR: Exited with returncode 1.
I also dont want to loose user settings in Roundcube like adressbook, signature etc...
Is there any help outside? I was investigating this DB error this hole night and could restore the DB, so most now works like wordpress users -> homepages. entering plesk with admin-user. I think I must reset the DB-user password only somewhere..... for using webmail again.
But the update missing error seems another error. This was from an error during an auto-update procedure month ago...
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