Applicable to:
- Plesk Multi Server
- Plesk Onyx for Linux
Symptoms
- Unable to sync a service node with a management node in Plesk Multi Server. The following error is shown:
PLESK_ERROR: Failed API request: Unable to open the source file. File does not exist
- The following error could be found on management node in
/var/log/plesk/panel/log
:CONFIG_TEXT: DEBUG [extension/plesk-multi-server] Remote Plesk API-RPC request to 203.0.113.2:
<packet version='1.6.9.0'><extension>
<call>
<plesk-multi-server-node>
<cli>
<util>extension</util>
<args>a:2:{i:0;s:9:"--install";i:1;s:6:" extension_name ";}</args>
<env>a:1:{s:4:"LANG";s:11:"en_US.UTF-8";}</env>
</cli>
</plesk-multi-server-node> - Unable to manually install the extension directly on the service node:
# plesk bin extension -i extension_name
The extension extension_name is not allowed for installation. - The extension could be found in section
"extensions":{"buyUrl":"","blacklist"
in/usr/local/psa/admin/conf/customizations.conf:
# grep extension_name /usr/local/psa/admin/conf/customizations.conf
{"db":{"smb_settings"... "extensions":{"buyUrl":"","blacklist":" ... extension_name,...
Cause
Impossible to install a required extension on Service node due to license custom settings. The required extension is blacklisted for the license at Plesk Partner's Central.
Resolution
Check the custom settings for the license from the service node in Plesk Partner's Central interface: https://central.plesk.com/ui or contact Plesk Licensing and Purchase Support.
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