Plesk
FR:PPM-2528
kb: technical
ABT: Group B
Symptoms
- Default Plesk web page or other incorrect web page is shown
when example.com is opened in web browser instead of the desired web page. - On opening the complete URL to the website in webbrowser, for example
https://example.com/index.php
orhttps://example.com/Default.aspx
the correct website is shown.
Cause
A different document is processed before the desired Index file
on Plesk for Linux or Default document
on Plesk for Windows.
Resolution
Change index file load order:
For Plesk for Linux
- Log into Plesk
- Go to Domains > example.com > Apache & Nginx Settings
- Enable checkbox Enter values for Index files
- Remove the line with unwanted document from the list, or add desired file name to the first line
- Click OK
For Plesk for Windows
- Log into Plesk
- Go to Domains > example.com > IIS Settings
- Enable checkbox Enter values for Default documents
- Remove the line with unwanted document from the list, or add desired file name to the first line
- Click OK
Alternatively, remove unwanted document in website's document root:
- Log into Plesk
- Go to Domains > example.com > File Manager
- Open domain's document root directory, for example folder
httpdocs
- Rename or delete the incorrect file which is served before the desired document, for example the file
index.html
:
Comments
3 comments
Thank you for this help! Fixed my problem immediately (did not know what was going on).
Our problem is similar except that the index.html keeps reappearing. How do we prevent that from happening? It's only one website. the others seem to be fine.
Hello, @Curtis Maurand
Please submit ticket to us https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support- and describe the conditions under which the file appears again.
Please sign in to leave a comment.