Applicable to:
- Plesk for Linux
Symptoms
- Unable to start Plesk Premium Antivirus
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From Plesk UI: Tools & Settings > Services Management > Plesk Premium Antivirus:
PLESK_ERROR: Unable to manage service by drwebmng: ('start', 'drweb'). Error: /usr/local/psa/admin/bin/drwebmng[17360]: Unable to start drweb antivirus daemon
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From the command-line interface:
# service drwebd start
Key file: /opt/drweb/drweb32.key - Key file was not found! (No such file or directory)
A path to a valid license key file was not specified.
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The following error appears during enabling Plesk Premium Antivirus on a mailbox:
PLESK_ERROR: Error: drwebmng failed: /usr/local/psa/admin/bin/drwebmng[20358]: Unable to update drweb antivirus service state: not all changes might be applied drwebmng: Some errors occurred in handlers actions System error 2: No such file or directory
Cause
drweb
package is corrupted or installed from the 3rd-party repository.
Resolution
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Connect to the server via SSH.
Note: if direct SSH access to the server is not possible, contact server administrator for further assistance.
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Remove Plesk Premium Antivirus:
# plesk installer --select-release-current --remove-component drweb
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Remove corresponding directories:
# rm -rf /var/drweb/ /etc/drweb/
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Check if 3rd party repository is being used:
# yum repolist | grep -i drweb
drweb DrWeb - stable 72-
If yes, disable it:
Edit corresponding repository file and changeenabled
option to 0:# grep enabled /etc/yum.repos.d/drweb-yum-x86_64.repo
enabled=0Note: the repository name may differ.
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Re-install Plesk Premium Antivirus:
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via Plesk UI:
In Plesk> Tools & Settings > Updates and Upgrades > Add and Remove Product Components > Mail hosting > Plesk Premium Antivirus:
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via command-line interface:
# plesk installer --select-release-current --install-component drweb
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Run the Plesk Premium Antivirus service:
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via Plesk UI:
Tools & Settings > Services Management > Plesk Premium Antivirus:
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via command-line interface:
# service drwebd start
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Comments
20 comments
This solution not work for me. I found the solution here:
https://support.plesk.com/hc/en-us/articles/115001211585-Premium-Antivirus-service-fails-to-start-Plesk-authorization-failed-HTTP-request-error
Hello @Fossy,
Thank you for sharing your user experience.
Glad to hear that another article helped.
Cross-links will be added to these 2 articles to improve their findability.
the solution ends with the same error:
mail:~# service drwebd start
Starting Dr.Web drwebd...
Dr.Web (R) daemon for Linux/Plesk Edition v6.0.2.1
Copyright (c) Igor Daniloff, 1992-2019
Doctor Web, Moscow, Russia
Support service: http://support.drweb.com
To purchase: http://buy.drweb.com
Key file: /opt/drweb/drweb32.key - Key file was not found! (No such file or directory)
A path to a valid license key file was not specified.
Plesk authorization failed: HTTP request error [35]
Error: Plesk Software not running.
this solution is working:
https://support.plesk.com/hc/en-us/articles/115001211585-Premium-Antivirus-service-fails-to-start-Plesk-authorization-failed-HTTP-request-error
Add TLSv1 in the ssl_protocols in the
/etc/sw-cp-server/conf.d/ssl.conf
, e.g:ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
Restart
sw-cp-server
anddrwebd
services:# service sw-cp-server restart
# service drwebd start
@Jan Bludau,
Hi!
Glad to know that you have found the answer in our Knowledge Base.
Dank @plesk, dass dies bestehende :-)
Ich hoffe, ich konnte einige Menschen helfen, die @google suchen und fand diese erste „/opt/drweb/drweb32.key - Key file was not found!“
None of the solutions on this page work. I have exactly the same error messages as described here and on the alternative suggestion linked here. However, nothing works. Completely uninstalling Plesk Antivirus and reinstalling leads to the same errors. I have searched high and low for a solution. Nothing works...! Any ideas...?
Hello @Graham Jones,
Please contact Plesk support for the deep investigation of the issue:
https://support.plesk.com/hc/en-us/requests/new
Hi Maxim
I have now been able to resolve the issue. I managed to log in via FTP. I then deleted the ssl.conf file, then rebooted the server.
Upon checking the newly created SSL settings in /etc/sw-cp-server/conf.d/ssl.conf they were exactly the same as the file I deleted. Nothing was different, except it was a new ssl.conf file.
So, a bit of a mystery, but everything is working OK now.
Hello @Graham Jones,
Glad to know that you have found the solution!
It may be helpful to other Plesk users.
service drwebd restart gives me:
Key file: /opt/drweb/drweb32.key - License key file error!
A path to a valid license key file was not specified.
Daemon is enabled for protecting 14 e-mail`s:
But reinstalling didn't solve my problem, I do have a valid license and there are no TLS / SSL problems either? Do I have to switch to Kaspersky now?
Hello @Dennis,
Could you, please, submit a request to Plesk Technical Support for further investigation: https://support.plesk.com/hc/en-us/requests/new
You may use Plesk Premium Antivirus license number in the request form.
@Ivan: I can't submit any request - I can fill out the form, but there is no button to submit it...
Dennis Köhler
"Submit" button appears after license number and fields marked with "*" are filled in.
Hello
Switching the tls version to "Modern" caused this issue.
Setting back the option to "Intermediate (recommended)" allowed me to restard drweb.
This occurs under
I have some other servers under Ubuntu 18 that are not concerned by the issue
Hope this helps
Hello,
I'm not able to install Dr.web.
I receive this error:
tarting Dr.Web drwebd...
Dr.Web (R) daemon for Linux/Plesk Edition v6.0.2.1
Copyright (c) Igor Daniloff, 1992-2020
Doctor Web, Moscow, Russia
Support service: http://support.drweb.com
To purchase: http://buy.drweb.com
Key file: /opt/drweb/drweb32.key - Key file was not found! (No such file or directory)
A path to a valid license key file was not specified.
Plesk authorization failed: HTTP request error [35]
Error: Plesk Software not running.
and then this error:
Unable to start service: Unable to manage service by drwebmng: ('start', 'drweb'). Error: /usr/local/psa/admin/bin/drwebmng[26487]: Unable to start drweb antivirus daemon
Thank you
@Pigr_46,
Check whether TLSv1 is enabled for
sw-cp-server
:# plesk bin server_pref --show | grep ssl-protocols
In case TLSv1 won't be mentioned in the output, enable it using the command below as it's required for Plesk Premium Antivirus:
# plesk bin server_pref -u -ssl-protocols 'TLSv1 TLSv1.1 TLSv1.2 TLSv1.3'
After that start the antivirus process again.
If the issue persists, don't hesitate to contact our Technical Support Team, so they may check the issue in details.
@everyone,
Please inspect the syslog file before attempting to implement any of the solutions provided here.
It certainly is not a good idea to mess with SSL config, if that really is not the root cause of the problem.
In most cases, you will find the following log entries many times in /var/log/syslog :
drwebd[....]: Key file: /opt/drweb/drweb32.key - Key file was not found! (No such file or directory)
drwebd[....]: A path to a valid license key file was not specified.
drwebd[....]: Plesk authorization failed: HTTP request error [35]
drwebd[....]: Error: Plesk Software not running.
and in some cases, you will find each of the above mentioned lines logged twice.
The log entry
drwebd[....]: Plesk authorization failed: HTTP request error [35]
is commonly associated with a solution involving messing about with SSL config.
The log entry
drwebd[....]: Key file: /opt/drweb/drweb32.key - Key file was not found! (No such file or directory)
is commonly associated with a solution involving uninstalling and re-installing Plesk Premium Antivirus (DrWeb).
In fact, both solutions are often not really necessary - just re-install the DrWeb license key!
That is often all that is required to solve the issue.
Please note that (removing and) re-installing Plesk Premium Antivirus (DrWeb), as suggested by this KB article, often will require that you need to re-install the DrWeb license.
Hope the above helps a tiny bit.......
Hi Michiel de Ruijter
Please give me a clue: HOW do I re-install the DrWeb license key?
It seems to be ambiguous whether Plesk Obsidian includes Plesk Premium Antivirus by DrWeb that is free for a small number (10? 14?) of mailboxes.
/opt/drweb/drweb32.key is missing.
/etc/drweb/plesk.key exists but is not in the correct format for DrWeb.
Thanks
Doesn't work, this guide dont fix the problem
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