Applicable to:
- Plesk for Linux
Symptoms
-
Domain
example.com
was secured with Let's Encrypt on Plesk server. -
Domain
example.com
was removed from the server at Domains > example.com > Remove. -
Let's Encrypt notifications about the removed domain are still being sent to a customer's email which was specified during SSL certificate request.
Cause
This is Let's Encrypt bug with ID EXTLETSENC-643, which is planned to be fixed in future updates.
Directory /usr/local/psa/var/modules/sslit/etc/live/example.com/
exists on the server or/and the certificate is presented in the database:
# plesk db "SELECT * FROM certificates WHERE name LIKE '%example.com%'"
Resolution
According to Let's Encrypt documentation, each email should contain an 'unsubscribe' link. In case of expiry notifications for one domain, use such links to unsubscribe. In other cases:
-
Move or delete the
/usr/local/psa/var/modules/sslit/etc/live/example.com/
directory:# mv /usr/local/psa/var/modules/sslit/etc/live/example.com/ ~/
-
Move or delete files mentioning the removed domain from the
./orders
folder# for i in $(grep -irl "example.com" /usr/local/psa/var/modules/sslit/orders/); do mv $i ~/; done
Note: Notifications are sent with a 1-day delay, therefore the last one may be received after applying the solution.
-
If the record in the database exists remove it as well:
# plesk db "DELETE FROM certificates WHERE name='certificate_name'"
Note: Specify the full certificate name in bold (e.g. Let's Encrypt example.com).
Comments
6 comments
Despite the steps from above, the notifications are sent every day. This is so annoying. How do you disable them completely?
@Miomir Besarabic,
Check this article about disabling Let's Encrypt notifications.
Thank you, but why try Let's Encrypt to renew certificate for domain if we unsigned certificate from domain and removed it?
@Miomir Besarabic,
Usually, it happens when the domain wasn't deleted properly.
In case additional details are needed, please submit a request to our Support Team before solving the issue, so Support Team could check it in details.
How to fix this on Plesk for Windows?
Hello Ward Pieters
So far we've met this issue on Linux only.
Could you submit a support request? Additional research is needed to provide a solution.
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