How to install different Ruby versions on Plesk server?

Follow

Comments

2 comments

  • Avatar
    Marco T

    This automatically installs bundler with the most recent version.

    If this causes an issue with the "Bundle Install" function in plesk, go check the "BUNDLED WITH" line in the Gemfile.lock file at the root of the Ruby application. It will contain the version of the bundler that was used when the application was created.

    run

    `/opt/plesk/ruby/2.4.0-dev/bin/gem uninstall bundler`  

    and

    `/opt/plesk/ruby/2.4.0-dev/bin/gem install bundler -v <VERSION SPECIFIED IN Gemfile.lock>`  

    then try to click "Bundle Install" again.

    1
    Comment actions Permalink
  • Avatar
    Alisa Kasyanova

    @Marco T
    Thank you for sharing this information! I am sure that other Pleskians will find it helpful :)

    1
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request