Unable to open Updates & Upgrades on Plesk for Linux: ERR_CONNECTION_TIMED_OUT

Follow

Comments

6 comments

  • Avatar
    Daerik Khan

    I know that we always want to think it's a firewall issue, which at times it is; mostly on new servers. However, I manage 15 servers that utilize Plesk and it used to only occur infrequently on older versions that would just require removing the lock file. In recent updates, this issue has been happening more frequently to the point I handle most changes via CLI just to avoid the headache. Naturally, this is unfair for some not-so-savvy tech users.

    0
    Comment actions Permalink
  • Avatar
    Alexandr Redikultsev

    Hello, @Daerik Khan!

    There indeed can be some issues when Web Installer updates itself and the update require some additional time and failing with timeout because it was not able to update itself in time.

    In such case, next try from web interface after a couple of minutes should help.

    0
    Comment actions Permalink
  • Avatar
    Vojjin

    After clicking updates/upgrades I'm redirected to  https://.........com:8443/admin/update/product/ and then to https://...........com:8447/?secret=&locale=en-US and I'm getting error ERR_TIMED_OUT. My port is opened, 

    [root@packet ~]# iptables -nL | grep 8447
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:8447

    Are there ant other reason why I'm receiving this, since I haven't update Plesk and system from October last year.

    0
    Comment actions Permalink
  • Avatar
    Julian Bonpland Mignaquy

    Hi @Vojjin,

    I see that the port is open. Could you open a ticket with us in order to check on this issue? https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-

    0
    Comment actions Permalink
  • Avatar
    Thomas Seifert (Edited )

    @Vojjin

    open a ssh session to the server, install updates with "plesk installer update" after this you can reach the Updates/Upgrades Webseite under port 8447 again without connection timeout.

    0
    Comment actions Permalink
  • Avatar
    Vojjin

    Hello.. Problem is solved. Reason was that yum hangs for a very long time. I have just stopped yum process and everything work as expected :)

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request