Applicable to:
- Plesk Onyx for Linux
Symptoms
-
Unable to open Plesk UI via port 8447. The following error is shown in a browser:
PLESK_INFO: This site can’t be reached example.com took too long to respond.
ERR_CONNECTION_TIMED_OUT
PLESK_INFO: This site can’t be reached
PLESK_INFO: The connection has timed out
PLESK_INFO: ERR_CONNECTION_RESET
-
The
nmap
utility shows that port 8447 is filtered:# nmap -p 8447 example.com
PORT STATE SERVICE
8447/tcp filtered unknown
Cause
Port 8447 that is used by Plesk Installer is filtered/closed with a firewall.
Resolution
Open port 8447 in the firewall:
Note: if this is an Amazon installation, refer to this documentation page.
Note: if this is a Google installation, refer to this documentation page.
-
Go to Tools & Settings > Firewall and click the Enable button.
Note: If the Plesk Firewall component is not installed/missing, move to the command-line section.
-
Click the rule Plesk installer > select Allow > and click OK.
-
If port 8447 is still filtered/closed, check if there are any intermediate firewalls.
Contact a network administrator for further troubleshooting.
-
Connect to the server via SSH.
-
Check the status of port 8447:
# iptables -nL | grep 8447
-
For some Linux distributions (CentOS 7, Debian, Ubuntu), additional package
iptables-persistent
oriptables-services
is required to be installed before runningiptables-save
:-
For CentOS 7:
# yum install iptables-services
# systemctl enable iptables-services -
For Debian:
# apt install iptables-persistent
-
-
Allow incoming connections to port 8447:
-
For CentOS/RHEL-based distributions:
# iptables -I INPUT 1 -p tcp --dport=8447 -j ACCEPT
# service iptables save -
For Debian/Ubuntu-based distributions:
# iptables -I INPUT 1 -p tcp --dport=8447 -j ACCEPT
# iptables-save > /etc/iptables/rules.v4
-
-
If port 8447 is still filtered/closed, check if there are any intermediate firewalls.
Contact a network administrator for further troubleshooting.
Alternatively it is possible to use command line interface (CLI) of plesk installer: How to install / uninstall Plesk components?
Comments
9 comments
I know that we always want to think it's a firewall issue, which at times it is; mostly on new servers. However, I manage 15 servers that utilize Plesk and it used to only occur infrequently on older versions that would just require removing the lock file. In recent updates, this issue has been happening more frequently to the point I handle most changes via CLI just to avoid the headache. Naturally, this is unfair for some not-so-savvy tech users.
Hello, @Daerik Khan!
There indeed can be some issues when Web Installer updates itself and the update require some additional time and failing with timeout because it was not able to update itself in time.
In such case, next try from web interface after a couple of minutes should help.
After clicking updates/upgrades I'm redirected to https://.........com:8443/admin/update/product/ and then to https://...........com:8447/?secret=&locale=en-US and I'm getting error ERR_TIMED_OUT. My port is opened,
[root@packet ~]# iptables -nL | grep 8447
ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:8447
Are there ant other reason why I'm receiving this, since I haven't update Plesk and system from October last year.
Hi @Vojjin,
I see that the port is open. Could you open a ticket with us in order to check on this issue? https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
@Vojjin
open a ssh session to the server, install updates with "plesk installer update" after this you can reach the Updates/Upgrades Webseite under port 8447 again without connection timeout.
Hello.. Problem is solved. Reason was that yum hangs for a very long time. I have just stopped yum process and everything work as expected :)
When I've tried to update Plesk Obsidian I received error ERR_TIMED_OUT. To me solution was easy. In terminal as root find the corresponding "installer" process
Find the process pid and kill it using command
After that all started working fine (check example below)
tools & Settings > Firewall does not exist on tools and settings
Click the rule Plesk installer ¿where is this?
Help must have better descriptions, not so abstract... still looking for "rule Plesk Installer" in Web Application Firewall
The Port was already open, This has to do with the running process for the installer.
I solved it with help of the comment:
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