Plesk upgrade fails: packages have unmet dependencies

Created:

2017-05-15 18:12:48 UTC

Modified:

2017-08-16 16:53:04 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails: packages have unmet dependencies

Applicable to:

  • Plesk for Linux

Symptoms

Plesk Upgrade fails with the following error:

The following packages have unmet dependencies:
apache2 : Depends: apache2-bin (= 2.4.7-1ubuntu4.15) but 2.4.7-1ubuntu4.13 is to be installed
Depends: apache2-data (= 2.4.7-1ubuntu4.15) but 2.4.7-1ubuntu4.13 is to be installed

Cause

Inconsistent package dependencies.

Resolution

  1. Manually download packages:
    # apt-get download apache2 apache2-bin apache2-data
  2. Install packages using dpkg utility:
    # dpkg -i apache2*
  3. Continue the upgrade.
Have more questions? Submit a request
Please sign in to leave a comment.