Unable to install Let's Encrypt SSL certificate on LiteSpeed web server: Invalid response: 502 Bad Gateway

Created:

2017-05-15 10:26:59 UTC

Modified:

2017-08-16 18:27:18 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install Let's Encrypt SSL certificate on LiteSpeed web server: Invalid response: 502 Bad Gateway

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Unable to install Let's Encrypt SSL certificate on a cloned WordPress instance:

Error: Let's Encrypt SSL certificate installation failed: Challenge marked as invalid. Details: Invalid response from http://test.example.com/.well-known/acme-challenge/nWGovlOgRFg588s5ds2LwgK8GmL2-jXC_Qemi9eB7DD5I: "<html>
<head><title>502 Bad Gateway</title></head>
<body bgcolor="white">
<center><h1>502 Bad Gateway</h1></center>
<hr><cen"

Cause

LiteSpeed web server is used on a server, which has been installed separately from Plesk.

Resolution

  1. Enable nginx only for a domain by clearing the checkbox Proxy mode at Plesk > Domains > example.com > Apache & nginx Settings
  2. Install the Let's Encrypt SSL certificate again
Have more questions? Submit a request
Please sign in to leave a comment.