Unable to install Plesk microupdates: Attempt to remove 'php71w-common' to resolve conflict has failed

Created:

2017-05-13 19:50:21 UTC

Modified:

2017-08-16 16:48:09 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install Plesk microupdates: Attempt to remove 'php71w-common' to resolve conflict has failed

Applicable to:

  • Plesk for Linux

Symptoms

  • The following error is shown in Plesk:

    PLESK_ERROR:Failed to update Plesk. To solve this problem, you can send the update log to Plesk support. View the update logs (May 13, 2017). View the update logs (May 12, 2017). Copy the logs to your computer before you close this message. To close this message, click here.

  • The following error can be found in /var/log/plesk/install/autoinstaller3.log:

    No package matched to remove: php71w-common Attempt to remove 'php71w-common' to resolve conflict has failed Attempt to remove 'php-common' to resolve conflict has succeeded Exception: Failed to solve dependencies: php-gd-5.4.16-42.el7.x86_64 requires php-common(x86-64) = 5.4.16-42.el7 php-xml-5.4.16-42.el7.x86_64 requires php-common(x86-64) = 5.4.16-42.el7 php-mbstring-5.4.16-42.el7.x86_64 requires php-common(x86-64) = 5.4.16-42.el7 php-pdo-5.4.16-42.el7.x86_64 requires php-common(x86-64) = 5.4.16-42.el7
  • Webtatic repository is enabled on the system:

    # cat /etc/yum.repos.d/webtatic.repo | grep enabled
    enabled=1
    enabled=1
    enabled=1

Cause

php71w-common package conflicts with packages installed by Plesk.

Resolution

Disable Webtatic Yum repository by setting the value of enabled to 0 in the file webtatic.repo :

# cat /etc/yum.repos.d/webtatic.repo | grep enabled
enabled=0
enabled=0
enabled=0
Have more questions? Submit a request
Please sign in to leave a comment.