Private IP is showing in preview URL instead of public IP if the Plesk is behind NAT

Follow

Comments

7 comments

  • Avatar
    Bulat Tsydenov

    @chris Can you please provide the screenshot of DNS settings where you applied the solution?

  • Avatar
    chris

    I have made the change to the exact solution above and it's still not working

  • Avatar
    chris

  • Avatar
    Andrey Ivanov

    Hello Chris,

    Please change your record to the following:

    *.172-23-88-10.donate.orphansinneed.org.uk    A    185.162.255.210

    The article was modified accordingly.

  • Avatar
    chris

    Hi, its now working. 

    I just ran this and now its responded

    /usr/local/psa/admin/sbin/nginxmng --enable 

      I have removed the DNS fix and all now seems fine.

     

    Regards

    Chris

  • Avatar
    chris

    Solution doesn't work?

  • Avatar
    Nikolay Zhmuk

    @chris The domain that used for Quick Preview should be resolvable. I checked that it is not:
    # dig +short donate.orphansinneed.org.uk @8.8.8.8
    #

    Port 53 is filtered:
    # nmap -Pn 185.162.255.210 -p 53

    Starting Nmap 6.47 ( http://nmap.org ) at 2017-10-03 06:28 +07
    Nmap scan report for 185.162.255.210
    Host is up.
    PORT STATE SERVICE
    53/tcp filtered domain

    Nmap done: 1 IP address (1 host up) scanned in 2.13 seconds
    Make sure that everything is configured correctly on registrar's side and all necessary ports are open in the server's firewall

Please sign in to leave a comment.

Have more questions? Submit a request