Unable to use Panel Migrator Agent: the source server does not meet requirements

Created:

2017-05-11 05:07:53 UTC

Modified:

2017-08-16 16:41:57 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to use Panel Migrator Agent: the source server does not meet requirements

Applicable to:

  • Plesk Onyx for Windows
  • Plesk 12.5 for Windows

Symptoms

  • When migration starts, Plesk Migration Agent fails.
  • The following error appears when starting migration:

    Unable to use Panel Migrator Agent: the source server 'source' (203.0.113.2) does not meet requirements.
    Please make sure that Microsoft .NET Framework version 4 is installed.
  • Event Viewer shows the following:
    Faulting application name: WINAgentMng.exe, version: 12.0.8.20605, time stamp: 0x57b3e78a
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.23418, time stamp: 0x5708a7e4
    Exception code: 0xe0434f4d
    Fault offset: 0x0000c54f
    Faulting process id: 0x%9
    Faulting application start time: 0x%10
    Faulting application path: %11
    Faulting module path: %12
    Report Id: %13
  • Debug log of Plesk Migration Agent contents the following:
    Command stderr: 
    Unhandled Exception: System.BadImageFormatException: Could not load file or assembly 'WINAgentMng.exe' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.
    File name: 'WINAgentMng.exe'
  • OS version of the source server is Windows Server 2008 R2 SP1 or older.

Cause

.NET 4 is missing from the source server.

Resolution

Download .NET 4.x from Microsoft official website and install it.

Link for downloading Web Installer: https://www.microsoft.com/en-us/download/details.aspx?id=17851

Have more questions? Submit a request
Please sign in to leave a comment.