Constant email notification about the expiration of the previous version of the license key

Created:

2017-05-10 12:36:42 UTC

Modified:

2017-08-16 16:29:20 UTC

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Constant email notification about the expiration of the previous version of the license key

Applicable to:

  • Plesk for Linux

Symptoms

  • Plesk administrator receives the following email notification every day:

    Unable to update PLSK.12345678.0005: an error occurred while processing your key. 
    You can try to retrieve the key manually in Plesk (Tools & Settings > License Management) or let Plesk try to update it in the next 24 hours. If you do not want to receive this notification any more, remove this key from Plesk.
    The license key is expired. Some features can be unavailable. Please contact your hosting provider.
  • However, the current Plesk license (which is shown in Tools & Settings > License Management ) is PLSK.12345678.0006.

Cause

There are two license key files in the /etc/sw/keys/keys/ directory:

# ls /etc/sw/keys/keys/key*
/etc/sw/keys/keys/keyXXA1b2C3
/etc/sw/keys/keys/keyXXd4E5F6

Resolution

  1. Go to Plesk > Tools & Settings > Licence Management and click Retrieve Keys .
  2. If previous step did not help. Find the previous version of the license key file:

    # grep -ri 0005 /etc/sw/keys/
    /etc/sw/keys/keys/keyXXd4E5F6: <core:key-version core:type="string">0005</core:key-version>
    /etc/sw/keys/registry.xml:<member><name>PLSK.12345678.0005</name>

  3. Move the found file to the /etc/sw/keys/backup/ directory:

    # mv /etc/sw/keys/keys/keyXXd4E5F6 /etc/sw/keys/backup/

  4. Remove the /etc/sw/keys/registry.xml file and recreate it by logging out and logging back in to Plesk.
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