Cannot upgrade Plesk: You are running inside VZ container. KernelCare has to execute on host node instead.

Created:

2017-05-05 08:45:29 UTC

Modified:

2017-08-08 13:28:17 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot upgrade Plesk: You are running inside VZ container. KernelCare has to execute on host node instead.

Issue Symptoms

Unable to update Plesk, the following error is shown:

Errors were encountered while processing:
 kernelcare
E: Sub-process /usr/bin/dpkg returned an error code (1)

insmod: ERROR: could not insert module /var/cache/kcare/44b6730e07513357c787173d9f81ec0c5c9ce8a5/kcare.ko: Operation not permitted
You are running inside VZ container. KernelCare has to execute on host node instead.
dpkg: error processing package kernelcare (--configure):
 subprocess installed post-installation script returned error exit status 1

Conditions

Internal issue in kernelcare package.

Resolution

  • login to your server under 'root' and update the package using apt:

# apt-get --only-upgrade install kernelcare

OR

  • login to Plesk > Tools & Settings > System Updates > click 'Check for Updates'
  • In Plesk > Tools & Settings > System Updates search for 'kernelcare' > click on this package > then click 'Update'.
  • then try to perform Plesk upgrade.
Have more questions? Submit a request
Please sign in to leave a comment.