How to update ionCube Loader to the latest version for PHP 5.6, 7.0, 7.1 or 7.2 shipped by Plesk?

Follow

Comments

6 comments

  • Avatar
    Jon Bishop

    I am running Plesk 17.8 and noticed that the update command below was wrong. It should be the second one...

    1. cp ioncube/ioncube_loader_lin_7.0.so /opt/plesk/php/7.0/lib64/php/modules/ioncube_loader_lin_7.0.so

    2. cp ioncube/ioncube_loader_lin_7.0.so /opt/plesk/php/7.0/lib/php/modules/ioncube_loader_lin_7.0.so

     

    The lib64 directory is just lib on my Ubuntu server.

  • Avatar
    Ivan Postnikov

    @Jon Bishop

    Thank for this note.
    Indeed, for Debian and Ubuntu it should be opt/plesk/php/X.X/lib/php/modules/ioncube_loader_lin_7.0.so.

    The article was updated.

  • Avatar
    Luis Zubeldia (Edited )

     

    what about php 7.2?

     

  • Avatar
    Ivan Postnikov

    @Luis, IonCube loader was not added yet for Plesk PHP 7.2. It will be added soon to Plesk PHP 7.2 package.

    For now, you may use workaround from this article.

  • Avatar
    Support2

    i do that steps one by one, but at the end, not installed that.

    what to do?

    or where i can check the logs about that?

  • Avatar
    Ivan Postnikov

    Hello @Support2,

    let me know were there any errors while following steps?

    What are Plesk version, OS, PHP version an which command you used to check that ionCube is installed correctly?

Please sign in to leave a comment.

Have more questions? Submit a request