How to update ionCube Loader to the latest version for PHP 5.6, 7.0 or 7.1 shipped by Plesk?

Follow

Comments

4 comments

  • Avatar
    Jon Bishop

    I am running Plesk 17.8 and noticed that the update command below was wrong. It should be the second one...

    1. cp ioncube/ioncube_loader_lin_7.0.so /opt/plesk/php/7.0/lib64/php/modules/ioncube_loader_lin_7.0.so

    2. cp ioncube/ioncube_loader_lin_7.0.so /opt/plesk/php/7.0/lib/php/modules/ioncube_loader_lin_7.0.so

     

    The lib64 directory is just lib on my Ubuntu server.

  • Avatar
    Ivan Postnikov

    @Jon Bishop

    Thank for this note.
    Indeed, for Debian and Ubuntu it should be opt/plesk/php/X.X/lib/php/modules/ioncube_loader_lin_7.0.so.

    The article was updated.

  • Avatar
    Luis Zubeldia (Edited )

     

    what about php 7.2?

     

  • Avatar
    Ivan Postnikov

    @Luis, IonCube loader was not added yet for Plesk PHP 7.2. It will be added soon to Plesk PHP 7.2 package.

    For now, you may use workaround from this article.

Please sign in to leave a comment.

Have more questions? Submit a request