Header of the sent message is changed and email message can not be delivered

Created:

2017-04-29 06:48:22 UTC

Modified:

2017-08-16 16:05:32 UTC

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Header of the sent message is changed and email message can not be delivered

Applicable to:

  • Plesk for Windows

Symptoms

  1. Plesk email notification with the password retrieving information are not delivered to client.

  2. External SMTP is not configured to allow relay mail from authenticated user.

  3. The following messages appear in /var/log/maillog :

    [2017.04.28] 22:01:03 [192.0.2.2][49064578] cmd: AUTH LOGIN 
    [2017.04.28] 22:01:03 [192.0.2.2][49064578] rsp: 334 *********
    [2017.04.28] 22:01:03 [192.0.2.2][49064578] Authenticating as johndoe@example.com
    [2017.04.28] 22:01:03 [192.0.2.2][49064578] rsp: 334 *********
    [2017.04.28] 22:01:03 [192.0.2.2][49064578] rsp: 235 Authentication successful
    [2017.04.28] 22:01:03 [192.0.2.2][49064578] Authenticated as johndoe@example.com
    [2017.04.28] 22:01:03 [192.0.2.2][49064578] cmd: MAIL FROM:<noreply@acme.com> ************NOTICE

    and

    [2017.04.28] 22:01:03 [10.240.0.5][49064578] rsp: 550 From address must match authenticated address 
    [2017.04.28] 22:01:03 [10.240.0.5][49064578] cmd: QUIT
    [2017.04.28] 22:01:03 [10.240.0.5][49064578] rsp: 221 Service closing transmission channel

Cause

Mail header always changes to no-reply@hostname when user requests password recovery since Plesk 12.0. These changes had been implemented to get rid of slamming of emails by spam filters and do not get a reject bulk mail flag going to mail services as Gmail, Yahoo, etc.

This is Plesk bug # PPPM-6261 which will be fixed in future updates.

Resolution

As a workaround, configure an external SMTP to allow relay mail from authenticated user. This is a mandatory condition for using external SMTP server in Plesk.

Also, the Mail header changing when Plesk sends notifications feature request is available for voting on Plesk User Voice portal.

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