Mail settings for subdomain are only accessible via main domain

Created:

2017-04-27 13:45:24 UTC

Modified:

2017-08-16 17:29:57 UTC

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Mail settings for subdomain are only accessible via main domain

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux

Symptoms

Mail settings are not accessible for a subdomain, but it is possible to access them via a main at Domains > example.com > Mail settings > "..." > foo.example.com

Upon enabling Activate mail service on this domain, an error occurs:

Error: There is no mail service for domain with id = 3. It must be created before call update

Cause

Mail related functionality is not accessible for subdomain, however not supported functionality is accessible in user interface.

This is Plesk bug with ID # PPPM-6133. It's planned to be fixed in future Plesk updates.

Resolution

There is no possible workaround at the moment.

Additional Information

In order to read more about mail settings for subdomains, follow the link: [How to] Create mail account for a subdomain

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